トラフィック接続障害 (Java)

問題

ログデータにトラフィック接続もしくはファイアウォールルールによるエラーがある。

例:

Jul 31, 2013 21:37:14 +0000 NewRelic 10
INFO: Failed to connect to collector.newrelic.com.:443 for My Application:java.net.
ConnectException: Connection refused:connect

もしくは

Jul 31, 2013 21:37:14 +0000 NewRelic 40
INFO: The data collector is temporarily unavailable.
This can happen periodically. In the event that availability of our servers 
is not restored after a period of time, 
then please report this to New Relic.
java.net.SocketException: Connection reset

対策

New Relic Java エージェントは、1分に1回接続を試みます。この障害が毎分発生しているなら、上記のような行を、検索して確認することで接続障害を特定できます。

エージェントは、接続できない間に発生しているメトリックデータをキャッシュします。停止が数分続いても、通常、New Relic APM ダッシュボード上の情報が失われることはありません。

断続的な接続の問題が原因で、時折短時間で上記のようなメッセージを多く発生させることがあります。数日おきに一度だけ発生し、すべてのデータが存在する場合はこれらのメッセージを無視しても問題ありません。

注: 障害が数分以上の間に毎分発生しつづける場合、エージェントはまったく接続できないし、何のデータも報告されません。その場合は、可用性の問​​題が発生していないことを確認してください。http://status.newrelic.com@newrelicstatus on Twitter. にて、New Relic の状態を確認してください。New Relic が何の問題も報告していない場合は、問題を解決するための情報を収集してください。

原因

New Relic の収集サーバーに接続するための臨時の障害が懸念材料ではありません。これらの障害は、New Relic UI で利用できるパフォーマンス統計に影響することはありません。

ログの内容通りではなく、このエラーは、通常、New Relic の収集が実際に利用できないことが原因ではなく、接続やファイアウォールトラフィックの障害が原因です。
New Relic は現在この問題に取り組んでいます。詳しくは、New Relic のサービスが使っている全IP リストを確認してください。