.NET エージェントのアップグレード

お使いのエージェントが最新版であるかどうかを確認するには、リリースノートをご覧ください。もし、現在お使いのバージョンが、2.2.x より前のバージョンの場合は、旧 .NET エージェントの更新をご覧ください。

エージェントのバージョンチェック

screen-net-version
Applications > (選択したあプリ) > Settings > Environment: Environment スナップショットは、ホスト、エージェント、バージョン、その他の詳細に関する現在の情報を表示します。

アプリに現在インストールされている .NET エージェントのバージョンをチェックする方法は以下のとおりです。

  1. New Relic APM メニューバーから、 Applications > (選択したアプリ) > Settings > Environment を選択します。
  2. Environment snapshot にあるアプリのインストールバージョンを確認します。

.NET エージェントの更新

アプリが、.NETエージェントのバージョン 2.2.x 以上の使用する場合は、以下の方法に従って、.NETエージェントを最新バージョンに更新してください。

  1. 利用対象のシステムに、.NET 3.5 がインストールされていることを確認します。
  2. 次のステップに進む前に、IIS を停止します
  3. お使いのアーキテクチャに適切なインストールパッケージをダウンロードして実行します。

  4. インストーラーパッケージ終了後、IIS を起動します。

旧 .NET エージェントの更新

2.2.x より古い .NET エージェントのバージョンを使っている場合は、以下の手順に従って、最新バージョンに更新してください。

  1. まず、IIS を停止します
  2. お使いの Windows バージョンにおける一般的な手順に従って、2.2.x より前の .NET エージェントをアンインストールします。
  3. お使いのアーキテクチャに適切なインストールパッケージをダウンロードして実行します。

  4. インストーラーパッケージ終了後、IIS を起動します。

注: 特に .NET エージェントが 2.2.x.よりも前のバージョンである場合は、お使いのオペレーティングシステムが、再起動を要求することがあります。

さらに詳しい情報

追加のドキュメントリソースは次のとおりです。