Ruby エージェントの要件とサポートしているフレームワーク

このドキュメントでは、New Relic Ruby エージェントの互換性ある OS、セキュリティ要件、サポートしているフレームワークを記載しています。

OS

Ruby エージェントは、Linux、Solaris、Mac OS X などの UNIX ライクな OS をサポートしています。

セキュリティ要件

データ収集に関する安全対策として、アプリケーションサーバーは SHA-2 (256 ビット) をサポートしている必要があります。 SHA-1 はサポート対象外です。

Ruby バージョン

名前 サポート対象 非推奨 試験版
JRuby ~> 1.6.0, ~> 1.7.0, ~> 9.0
MRI 1.8.7, 1.9.2, 1.9.3, 2.0.0, ~> 2.1.0, ~> 2.2.0, ~> 2.3.0 2.4.0-preview3
1.8.7 には、Ruby Enterprise Edition (REE) のサポートが含まれています。
1.8.7 & REE では、Gemfile/operating 環境に json gem が必要です。
1.8.6 で最後にサポートされたエージェントは 3.6.8.168 です。
Rubinius ~> 2.2.1

Web サーバー

名前 サポート対象 非推奨 試験版
passenger ~>2.2, ~>3.0, ~>4.0
puma ~>2.0 ~>1.0
rainbows! 4.5.0
thin ~>1.0
unicorn ~>4.0 ~>1.0, ~>2.0, ~>3.0
webrick
すべての Ruby エージェントサポートバージョンでサポートされています。

Web フレームワーク

名前 サポート対象 非推奨 試験版
grape >= 0.2.0
padrino ~>0.10
rack >= 1.1.0 ~>1.0.0
rails ~>2.1.0, ~>2.2.0, ~>2.3.0, ~3.0.0, ~>3.1.0, ~>3.2.0, ~>4.0.0, ~>4.1.0, ~>4.2.0, ~>5.0.0 ~>2.0.0
2.0.x で最後にサポートされたエージェントは、3.6.8.168 です。
sinatra ~>1.2.0, ~>1.3.0, ~>1.4.0

データベース

名前 サポート対象 非推奨 試験版
activerecord ~>2.1.0, ~>2.2.0, ~>2.3.0, ~>3.0.0, ~>3.1.0, ~>3.2.0, ~>4.0.0, ~>4.1.0, ~>4.2.0 ~>2.0.0
2.0.x で最後にサポートされたエージェントは、3.6.8.168 です。
datamapper ~>1.0
mongo ~>1.8, ~>2.1
redis ~> 3.0
sequel ~>3.37, ~>4.0

場合によっては、エージェントはインスタンスレベルのデータベース情報を収集します。詳しくは、インスタンスレベルのデータベース情報の互換性マトリックスをご覧ください。

バックグラウンドジョブ

名前 サポート対象 非推奨 試験版
delayed_job ~>2.0, ~>3.0, ~>4.0
rake ~> 10.0
resque ~>1.23.0 ~>1.22.0 >= 2.0
sidekiq ~>2.8, ~>3.4.2, ~>4.0

HTTP クライアント

名前 サポート対象 非推奨 試験版
Net::HTTP
すべての Ruby エージェントのバージョンでサポートされています。
curb >= 0.8.1
excon >= 0.10.1
httpclient >= 2.2.0
typhoeus >= 0.5.3
http.rb >= 0.9.9

その他

名前 サポート対象 非推奨 試験版
activemerchant >= 1.25.0
acts_as_solr
authlogic
dalli
memcache-client
sunspot

関連情報

関連する情報は以下のとおりです。