SAP の互換性と用件

この機能へのアクセス可否は、サブスリクプションレベルによります。SPA 監視機能は、New Relic Browser Pro のユーザーのみ利用可能です。

New Relic Browser のシングルページアプリケーション (SPA) 監視の設定を始める前に、New Relic SPA 監視機能に関する用件やデータ収集に関する以下の内容を確認ください。

Browser のエージェントバージョン

SPA 監視機能を利用するには、Browser エージェントのバージョン 885 以上が必要です。バージョンチェックと更新を行う方法は、ここの説明に従ってください。また、利用するには、SPA にアプリを追加する必要があります。

ブラウザ種別

SPA 監視機能は、addEventListener ブラウザ API と Navigation Timing API を利用できることがで前提となっております。これら両方の API は、Chrome (Google)、Firefox (Mozilla)、Safari (Apple)、Internet Explorer (Microsoft) バージョン 9 以上などの現在主要なブラウザ全てで利用可能となっています。

フレームワークに関する用件

ローレベルのブラウザ API をラップして、SPA の計測を行っています。そのため、どのフレームワークを使っているかは関知しません。SPA 計測は、 AngularReactEmberBackbone などのほとんどの SPA フレームワークと互換性があります。

ハッシュフラグメントの収集

New Relic は、ルート変更の URL からハッシュフラグメントを収集し、保存します。プライベートなことや機密データを渡すためにハッシュを使っている場合は、New Relic アカウントのユーザーからそのデータが見えることになります。New Relic Browser のデータ収集と送信に関しての詳しい情報は、New Relic Browser のセキュリティをご覧ください。

関連情報

関連する情報は以下のとおりです。