問題
Amazon EC2/ELB の API コールが多いと、AWS ダッシュボード で AWS の使用量が大幅に増加しているという状況を体験するでしょう。これは、Amazon からレート制限アラートとして現れます。
これにより、CloudWatch の請求が増える可能性があります。
原因
New Relic Infrastructure の Amazon インテグレーションは、インテグレーションに応じて異なるポーリング間隔に従って、AWS サービスに照会をかけます。ポーリング間隔は、AWS データが最新であることを保証し、各 AWS エンティティは各間隔でポーリングされます。大量の AWS インテグレーションエンティティを使っている場合、Amazon と New Relic の間で通信されるデータが制限される可能性があります。たとえば、200個の Elastic Load Balancer がある場合、New Relic
はこれらのロードバランサーのすべてのデータを取得する API 呼び出しを5分ごとに行います。
対策
スロットリングに関する問題が発生している場合は、次の2つの解決策があります。
- スロットリング問題の原因となっている AWS インテグレーションの接続を解除します。New Relic ELB インテグレーションは、Amazon ELB API への呼び出しを実行します。New Relic EC2、VPC、EBS インテグレーションは、Amazon EC2 API への呼び出しを実行します。
- New Relic サポート に連絡して、各 AWS の代わりに、呼出しを無効にしする方法について問い合わせてください。
関連情報
関連情報は以下のとおりです。
- CloudWatch 請求問題 (インテグレーションが、AWS CloudWatch の請求に関して与える影響ついての説明)
- Infrastructure における New Relic APM データ (Infrastructure で APM のデータを表示する方法の説明)
- Infrastructure エージェントの設定 (Infrastructure エージェントの振舞いを調整する方法)