Android 用 New Relic の互換性と要件

New Relic Mobile は、Google Play ストア、Amazon Appstore などの一般的なアプリケーションストアに準拠しています。モバイルアプリケーションに New Relic Mobile をインストールして設定する前に、互換性やその他の要件については、以下のガイドラインを確認してください。

Android の互換性

Android アプリが以下の New Relic Mobile の要件に会うことを確認ください。

New Relic Mobile Android の要件
OS Android 2.3 以上
Android 2.2 を利用している場合は、古いバージョンの 4.244.0 を使ってください。
API/SDK HttpURLConnection、OkHttp2 (バージョン 2.0 と 2.4 を除く)、OkHttp3 (バージョン 3.4)、AndroidHttpClient、Volley (バージョン 1.0.0)、Apache HTTP Client networking API

Android SDK Tools バージョン 21 以上でビルドし、必要に応じて以下でビルドします。

New Relic Mobile をインストールする前に、最新のバージョンにアップグレードしてください。

OkHttp 1.6 をお使いの場合は、古いバージョンの 4.244.0 を使ってください。

言語 Java
デバイス Android と互換性のあるデバイス (スマフォ、タブレット等)
ファイルサイズ APK をリリースすると、New Relic Mobile 分が約 48K 追加されます。
アーキテクチャ ARM、Intel Atom